A fix has been implemented and we are monitoring the results.
Posted Dec 26, 2025 - 15:32 GMT
Update
We are currently experiencing a delay in restoring service at the Bridgnorth Exchange due to an access issue related to a power fault. BT engineers have confirmed they will arrive on-site by 16:00 to assist with resolving the problem. Our engineer is already at the exchange and will begin work as soon as BT provides access. Thank you for your patience and understanding. We will share the next update as soon as more information becomes available.
Posted Dec 26, 2025 - 14:01 GMT
Update
We are continuing to investigate this issue.
Posted Dec 26, 2025 - 11:23 GMT
Update
Our engineers are working diligently to resolve the current outage as quickly as possible. We will share the next update as soon as we receive further information from our team. Thank you for your patience and understanding.
Posted Dec 26, 2025 - 08:06 GMT
Investigating
We are currently investigating this issue.
Posted Dec 25, 2025 - 23:55 GMT
This incident affected: Airband Fibre Networks (Shropshire).