We are continuing to monitor for any further issues.
Posted Apr 16, 2026 - 18:27 BST
Monitoring
We are pleased to say that the issue with the network has been fixed and all impacted customers are back online. Apologies again for the inconvenience caused and thank you for your understanding.
Posted Apr 16, 2026 - 18:26 BST
Update
Our third-party supplier has now diagnosed the issue and has informed us that the replacement equipment required is now on route to the impacted site. Their engineers will then conduct the necessary work to rectify the fault. We will update this page when we have more information or an expected resolution time. Thank you for your ongoing patience. Restoring your service is our number one priority.
Posted Apr 16, 2026 - 16:59 BST
Update
We apologise for the ongoing interruption to your service. The issue has been caused by a fault at one of our suppliers and as such is out of our direct control. We are working with them to find a solution to rectify service as soon as possible. As soon as we have an update from the third party, we will update this page. Thank you for your ongoing patience and understanding
Posted Apr 16, 2026 - 16:04 BST
Investigating
Our engineers are working hard to get all services back to normal. As soon as we have diagnosed the issue, we will communicate an expected resolution time. Thank you for your ongoing patience. Getting all customers back online with no disruption is our main priority. The next update will be via SMS and on this page on or before 16:00 on 16/04/2026.
Posted Apr 16, 2026 - 14:03 BST
This incident affected: Airband Fibre Networks (Devon) and Airband Wireless Networks (South Wales).