Loss of service affecting EX22 postcode area

Incident Report for Airband

Resolved

This incident has been resolved.
Posted Dec 21, 2025 - 10:47 GMT

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Dec 21, 2025 - 10:46 GMT

Update

We are continuing to investigate this issue.
Posted Dec 20, 2025 - 19:13 GMT

Update

Our engineer is currently on site investigating the issue. We’ll provide updates here as soon as there are any new developments.
Posted Dec 20, 2025 - 11:24 GMT

Investigating

We are currently investigating this issue.
Posted Dec 20, 2025 - 08:36 GMT
This incident affected: Airband Wireless Networks (Devon).