Loss of service affecting HR1, HR2, HR8, HR9 and GL18 postcode areas

Incident Report for Airband

Resolved

This incident has been resolved.
Posted Feb 20, 2026 - 17:09 GMT

Monitoring

We are pleased to say that the issue with the network has been fixed and all impacted customers are back online. Apologies again for the inconvenience caused and thank you for your understanding.
Posted Feb 20, 2026 - 15:23 GMT

Identified

Some customers will have restored. Please be assured we are working hard to restore the rest. Apologies, but the fix is taking longer than expected. Our engineers have set a new anticipated resolution time of 16:00. Please accept our apologies for the delay. Thank you for your ongoing patience. We will keep you updated via SMS and on this page if anything changes.
Posted Feb 20, 2026 - 14:32 GMT

Update

Our engineers have now diagnosed the problem with your connection and are working on fixing the issue. We are aiming to have all services fully restored by 15:00. If this changes, we will let you know. Thank you for your ongoing patience and understanding. The next update will be via SMS and on this page on or before 14:00
Posted Feb 20, 2026 - 11:47 GMT

Update

Our engineers are still diagnosing the issue that is causing a disruption to your service. Please be assured that getting all customers back online is our number one focus. Once we have identified the issue we will update all impacted customers on resolution time.
Posted Feb 19, 2026 - 17:51 GMT

Update

We are working hard to get all services restored as quickly as possible. Our engineers are running tests to identify the issue and put in place a fix. Please be assured that getting all customers back online is our number one focus. The next update will be via SMS and on this page on or before 17:00
Posted Feb 19, 2026 - 13:38 GMT

Update

Our engineers are working hard to get all services back to normal. As soon as we have diagnosed the issue, we will communicate an expected resolution time. Thank you for your ongoing patience. Getting all customers back online with no disruption is our main priority. The next update will be via SMS and on this page on or before 13:00 on 19/02/2026.
Posted Feb 19, 2026 - 11:35 GMT

Investigating

We are currently investigating this issue.
Posted Feb 19, 2026 - 11:34 GMT
This incident affected: Airband Fibre Networks (Herefordshire).