Loss of service affecting WV15, WV16 postcode areas

Incident Report for Airband

Resolved

This incident has been resolved.
Posted Jun 05, 2026 - 10:05 BST

Investigating

We are currently investigating this issue.
Posted Jun 05, 2026 - 08:58 BST
This incident affected: Airband Wireless Networks (Shropshire).