Loss of service affecting CF82 and CF45 Post code areas.

Incident Report for Airband

Resolved

This incident has been resolved.
Posted Feb 24, 2026 - 13:49 GMT

Update

Our engineers are still diagnosing the issue that is causing a disruption to your service. Please be assured that getting all customers back online is our number one focus. Once we have identified the issue, we will update all impacted customers on resolution time.
Posted Feb 24, 2026 - 10:59 GMT

Update

Our engineers are working hard to get all services back to normal. As soon as we have diagnosed the issue, we will communicate an expected resolution time. Thank you for your ongoing patience. Getting all customers back online with no disruption is our main priority.
Posted Feb 24, 2026 - 07:27 GMT

Investigating

We are currently investigating this issue.
Posted Feb 24, 2026 - 07:27 GMT
This incident affected: Airband Wireless Networks (South Wales).