Loss of service affecting LL22 postcode area

Incident Report for Airband

Resolved

This incident has been resolved.
Posted Sep 08, 2026 - 15:07 BST

Identified

Our network team have identified the problem with your connection and are now working on restoring service. Unfortunately the resolution time is taking longer than expected and the revised time for restoring your service is 15:00.
Posted Sep 08, 2026 - 09:43 BST
This incident affected: Airband Wireless Networks (Towyn).