Loss of service affecting WR10, WR15, HR6 and HR7 postcode areas

Incident Report for Airband

Resolved

This incident has been resolved.
Posted Feb 18, 2026 - 16:42 GMT

Monitoring

We are pleased to say that the issue with the network has been fixed and all impacted customers are back online. Apologies again for the inconvenience caused and thank you for your understanding.
Posted Feb 18, 2026 - 13:59 GMT

Update

Please be assured we are working hard to restore your service. Apologies, but the fix is taking longer than expected. Our engineers have set a new anticipated resolution time of 15:00. Please accept our apologies for the delay. Thank you for your ongoing patience. We will keep you updated via SMS and on this page if anything changes.
Posted Feb 18, 2026 - 12:58 GMT

Update

Our engineers have now diagnosed the problem with your connection and are working on fixing the issue. We are aiming to have all services fully restored by 13:00 18/02. If this changes, we will let you know. Thank you for your ongoing patience and understanding.
Posted Feb 17, 2026 - 22:03 GMT

Update

Our network team have identified the problem with your connection and are now working on restoring service. At this time we do not have an estimated time for resolution, we will communicate this to you as soon as possible. Thank you for your ongoing patience.
Posted Feb 17, 2026 - 16:35 GMT

Identified

Our engineers have now diagnosed the problem with your connection and are now working on fixing the issue. At this moment we do not have a resolution time, we will let you know when this changes. Thank you for your ongoing patience and understanding.
Posted Feb 17, 2026 - 15:44 GMT

Investigating

Our engineers are working hard to get all services back to normal. As soon as we have diagnosed the issue, we will communicate an expected resolution time. Thank you for your ongoing patience. Getting all customers back online with no disruption is our main priority.
Posted Feb 17, 2026 - 11:28 GMT
This incident affected: Airband Fibre Networks (Herefordshire).