Loss of service affecting LL22 postcode area

Incident Report for Airband

Resolved

This incident has been resolved.
Posted Apr 28, 2026 - 10:38 BST

Investigating

We are currently investigating this issue.
Posted Apr 28, 2026 - 09:39 BST
This incident affected: Airband Wireless Networks (Towyn).