Loss of service affecting TA4, TA22 and EX16 postcode areas

Incident Report for Airband

Resolved

This incident has been resolved.
Posted Mar 31, 2026 - 18:03 BST

Update

We are working hard to get all services restored as quickly as possible. Our engineers are running tests to identify the issue and put in place a fix. Please be assured that getting all customers back online is our number one focus.
Posted Mar 31, 2026 - 17:11 BST

Update

Our engineers are working hard to get all services back to normal. As soon as we have diagnosed the issue, we will communicate an expected resolution time. Thank you for your ongoing patience. Getting all customers back online with no disruption is our main priority.
Posted Mar 31, 2026 - 15:35 BST

Update

We are continuing to investigate this issue.
Posted Mar 31, 2026 - 15:33 BST

Investigating

We are currently investigating this issue.
Posted Mar 31, 2026 - 15:32 BST
This incident affected: Airband Wireless Networks (Devon).