Loss of service affecting LL22, LL29, LL30, LL61, LL55, LL28 postcode areas

Incident Report for Airband

Resolved

This incident has been resolved.
Posted Apr 18, 2026 - 17:58 BST

Investigating

We are currently investigating this issue.
Posted Apr 18, 2026 - 17:47 BST
This incident affected: Airband Wireless Networks (Towyn).