Loss of service affecting EX19 and EX20 postcode areas

Incident Report for Airband

Resolved

This incident has been resolved.
Posted Dec 25, 2025 - 09:34 GMT

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Dec 25, 2025 - 08:16 GMT

Update

Our engineer is en route to the site with an estimated arrival time of 09:00. We are working to restore service as quickly as possible and will provide further updates here. Thank you for your patience.
Posted Dec 25, 2025 - 07:53 GMT

Investigating

We are currently investigating this issue.
Posted Dec 25, 2025 - 07:36 GMT
This incident affected: Airband Wireless Networks (Devon).