Essential Maintenance

Incident Report for Airband

Resolved

This incident has been resolved.
Posted Feb 16, 2026 - 06:37 GMT

Identified

A 3rd party is conducting essential maintenance between 8 pm on 15/02/26 to 6 am on monday 16/02/26.

Customers in Oxfordshire and South Wales will be offline. Customers in Dartmore may experience interference with their connection during this time

We’re sorry for any inconvenience caused.
Posted Feb 15, 2026 - 21:01 GMT
This incident affected: Airband Fibre Networks (Oxfordshire) and Airband Wireless Networks (Devon, South Wales).