Loss of service affecting EX19, EX20, EX21, EX22, PL15 and PL16 postcode areas

Incident Report for Airband

Resolved

This incident has been resolved.
Posted Dec 25, 2025 - 10:15 GMT

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Dec 25, 2025 - 09:34 GMT

Identified

Our engineer is now on-site and working diligently to restore service by implementing a fix. We will provide further updates as soon as progress is made. Thank you for your continued patience.
Posted Dec 25, 2025 - 09:13 GMT

Update

The engineer’s arrival time has been confirmed. Updated ETA: 09:00.
Posted Dec 25, 2025 - 08:20 GMT

Update

Our engineer is en route to the site. We are working to restore service as quickly as possible and will provide further updates here. Thank you for your patience.
Posted Dec 25, 2025 - 07:13 GMT

Investigating

We are currently investigating this issue.
Posted Dec 24, 2025 - 19:36 GMT
This incident affected: Airband Wireless Networks (Devon).